Fedora 10

Having installed Fedora 10 I thought I would share some of my impressions. First some comments on installation and setup with a few problems and then some general thoughts.

Installation

I installed from a dvd which is the way I usually do it. I couldn’t use the update option as I was replacing a 32 bit Fedora 9 system with a 64 bit Fedora 10. I had used 64 bit before with F8 but when I updated to F9 I had a 32 bit dvd so I used that.

My only gripe with installation was the lack of an option to install Xfce as my desktop. My memory may be going but I think that was an option in earlier versions. So I installed the Kde version which gave me 4.1. 4.2 has just been released and I understand will be available via the regular Fedora update very soon. As usual I selected, and deselected, several packages. You must select customise now to do this during installation otherwise you will just get a default Gnome system.

Once installed I couldn’t get the internet working on my 3G modem. The Network Manager applet wasn’t appearing in the panel, neither was the Bluetooth applet. I had to reinstall a couple of times. It finally worked after I re-activated wifi in bios. Network Manager was in the panel and when I plugged in the modem I could activate it.

That done I started the update. There were nearly 300 packages to be updated and it took several hours. Not sure if it was an internet problem or slow mirrors, I have had problems with slow mirrors since then and that may be the cause.

Getting things working.

Next was to get things set up the way I like. Although I could select many of the packages I wanted during installation there were still many more to install afterwards. First I added the RPMFusion repos so I could get the good stuff like codecs that are not in the standard repos.

One of the first things I did was install Yumex, the graphical front end for Yum. It is the best package manager for yum systems, much better than the standard “add remove software”. Don’t why it isn’t used as the default.

Next I installed xfce. I have been using it as my desktop for a while now. I have KDE4 but can’t get used to it. It works much better than the F9 version but still doesn’t feel right.

At this stage I had a couple of problems, no sound and no bluetooth. The second was the most of a nuisance as I use a bluetooth mouse all the time and hate the touchpad on my Dell laptop. After some searching I found the command “hidd –-search”. If I pressed the reset button on the mouse as I ran that, as root, the mouse was recognised and worked. It didn’t remember after a restart so I had to do it everytime. Later I added the applet to the panel using the Launcher option in xfce and set it up that way. This seems to have solved the problem as it is remembered after a reboot now. Now I can disable the touchpad. I added gsynaptics to the panel and it works but isn’t remembered after a reboot.

The sound problem I’m not sure about. I tried playing with the settings, checking nothing was muted and the usual things but nothing worked. Then when I restarted one time it gave an error about not finding the sound system and resetting and everything started working so I left it alone after that. Amarok is working fine at the moment so that is all that matters. Almost, next I tried You Tube.

I found You Tube sound worked but was very soft. So soft I first thought there was no sound. The tv was on at the other end of the room and only when it went quiet for a moment did I realise there was some faint sounds coming from the computer. I turned up the volume and could hear something. Again I explored checking the volume control in the Multimedia menu. By chance I found there was a volume control under the Settings menu. It was set to 50% or less. I raised that and You Tube was suddenly very loud. Why is there more than one volume control and which one should we use? I decided to set both to full and use the application’s control to set the level for the current track. This is easiest for me.

One interesting thing is initially I didn’t install the Nvidia drivers from RPMFusion. I used nv for a while. I turned on the compositor in Xfce and some effects worked. They are basic just transparency, the shadows didn’t work as nv is a 2d driver not 3d. I needed to install the nvidia drivers to have Google Earth working properly.

Adobe has released native 64 bit flash and I installed it using a thread on Fedora forums. Although some people have had problems it is working well for me.

I added a few applications to the quick launch bar at the bottom of the screen. To find icons and apps I used the existing ones as a guide. I looked at the properties of the Firefox launcher and found what I was looking for in the same folders.

Impressions

Fedora 10 is a good stable release now. Most Fedoras take a couple of months to settle down so I don’t install as soon as they are released. This seems to work for me. I am liking it after living with it for a few days. That doesn’t mean it is perfect as there are a few things to sort but generally it is a good system

Outstanding issues.

Fedora removed dcop earlier and I was using it in a script for Conky to show the current playing track in Amarok. That doesn’t work and I will look into it too.

The settings to turn off the touchpad don’t “stick”. While typing I find I bump it occasionally and find myself typing in another part of the document. If I am doing a fair bit of typing I turn it off using Gsynaptics.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: